Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Turn signal wire harnesses for a 77 Volare Premier

  1. #11
    Aspen and Volare Super Moderator Rattle Trap's Avatar
    Join Date
    Oct 2015
    Location
    Huron, OH
    Country:
    United States
    Posts
    976
    Thanks
    200
    Thanked 102 Times in 83 Posts
    No mistake.

    Tag you're it!
    Attached Thumbnails Attached Thumbnails 2017-05-13 12.57.25.png  
    Volare Magnet

  2. #12
    Aspen and Volare Member VolareDave's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    My front turn signal wire harness still works,but the three locking tabs are rusted off on both harnesses.I bought two online,looked almost identical,but neither held the bulb in.I think only the 1976 an 77 have the right size tabs,if not I will just have to get out the silicone,which I don't really want to do.

  3. #13
    Aspen and Volare Member VolareDave's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    32
    Thanks
    1
    Thanked 1 Time in 1 Post
    Were you able to find any 1976-1977 front turn signal harnesses?My front turn signal wire harness still works,but the three locking tabs are rusted off on both harnesses.I bought two online,looked almost identical,but neither held the bulb in.I think only the 1976 an 77 have the right size tabs,if not I will just have to get out the silicone,which I don't really want to do.

  4. #14
    Aspen and Volare Super Moderator Rattle Trap's Avatar
    Join Date
    Oct 2015
    Location
    Huron, OH
    Country:
    United States
    Posts
    976
    Thanks
    200
    Thanked 102 Times in 83 Posts
    Do your replacement harnesses also have the metal tabs on the socket plugs like the early style? If so it shouldn't be more than a matter of using a good set of channel locks to put a tighter bend on them at their tight ends so they engage better. I'd almost bet the ones you got as "nos" are "nos" because of that small adjustment error in their original manufacture. It's almost easy fix to make em tight tho.
    Volare Magnet

  5. #15
    Aspen and Volare Super Member 77rr2x4s's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    810
    Thanks
    6
    Thanked 32 Times in 28 Posts
    I`ll look. I`m pretty sure I have them. They are mopar nos ones. I`ll let you know asap. I can try them on my 77 to make sure they are correct. Mike

  6. #16
    Aspen and Volare Super Member 77rr2x4s's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    810
    Thanks
    6
    Thanked 32 Times in 28 Posts
    I have them. Will post a pic shortly.

  7. #17
    Aspen and Volare Super Member 77rr2x4s's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    810
    Thanks
    6
    Thanked 32 Times in 28 Posts
    Ok. The socket fits my 77 grille and the bulb installs and holds properly. Here is a pic. They do not come with the bulb but since I put the one in I will include it.
    Attached Thumbnails Attached Thumbnails 3764863 lens.jpg   3764863lnens.jpg  

  8. #18
    Aspen and Volare Super Moderator Rattle Trap's Avatar
    Join Date
    Oct 2015
    Location
    Huron, OH
    Country:
    United States
    Posts
    976
    Thanks
    200
    Thanked 102 Times in 83 Posts
    Could it be that your gaskets have just shrunken from age Dave? I might not take anything more than a thicker gasket to make your sockets tight.
    Volare Magnet

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •