Results 1 to 8 of 8

Thread: 2013 up 5.7 Hemi spark plug question

  1. #1
    Super Moderator 77rr2x4s's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    1,776
    Thanks
    13
    Thanked 94 Times in 86 Posts

    2013 up 5.7 Hemi spark plug question

    Maybe someone here might know so I will ask. I see mopar shows part number SP143877AB for the mopar 2013 up spark plugs. I see rock auto shows NGK 92145 LZFR5CI-11 Laser Iridium Spark Plug as being the same. Are they different or exactly the same plug for less dollars?

  2. #2
    Aspen and Volare Super Moderator aspen79's Avatar
    Join Date
    Oct 2015
    Location
    Rib Mountain (Wausau) WI
    Country:
    United States
    Posts
    2,673
    Thanks
    3
    Thanked 211 Times in 171 Posts
    At work we use the aftermarket NGK plugs in the Hemi's and they work just fine. Not sure what, if any, difference there is between the Mopar NGK and parts store NGK's other than the p/n. On a Hemi Ram, you don't want to have to change the plugs too often. Not exactly an enjoyable job changing all 16 plugs, especially the back two cylinders on the driver side.
    1979 Aspen Sunrise 500". Bought in 1987 with 72,000 miles and a mighty E24 California emission 90hp leaning tower of power/4-speed
    1996 Dakota with a torque monster (not) 3.9L V-6 and automatic owned since 1998. Now demoted to winter duty
    2008 Ford Mustang V6, the new summer daily driver

  3. #3
    Super Moderator 77rr2x4s's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    1,776
    Thanks
    13
    Thanked 94 Times in 86 Posts
    I have put plugs in my 05 ram 5.7 and it wasn`t fun but I got through it ok while taking my time. My current Ram uses 100,000 mile plugs so when I do change them it may be the last time i have to change them out. LOL I can get the NGK plugs for as low as $112 for a set of 16. I found the mopar plugs for as low as $175 shipped. That was why I was questioning them. Thanks for the info.

  4. #4
    Aspen and Volare Super Moderator aspen79's Avatar
    Join Date
    Oct 2015
    Location
    Rib Mountain (Wausau) WI
    Country:
    United States
    Posts
    2,673
    Thanks
    3
    Thanked 211 Times in 171 Posts
    I suppose, I'd rather change plugs in a Hemi Ram than a mid to late 2000's F150 5.4L 3-valve. On those it usually isn't a matter of IF a plug will break while taking it out, it's a matter of how many. Then you get the 5.4L plug extractor kit out .............Not the best designed spark plugs ever made.
    1979 Aspen Sunrise 500". Bought in 1987 with 72,000 miles and a mighty E24 California emission 90hp leaning tower of power/4-speed
    1996 Dakota with a torque monster (not) 3.9L V-6 and automatic owned since 1998. Now demoted to winter duty
    2008 Ford Mustang V6, the new summer daily driver

  5. #5
    Super Moderator 77rr2x4s's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    1,776
    Thanks
    13
    Thanked 94 Times in 86 Posts
    What causes them to break? Just curious.

  6. #6
    Aspen and Volare Super Moderator aspen79's Avatar
    Join Date
    Oct 2015
    Location
    Rib Mountain (Wausau) WI
    Country:
    United States
    Posts
    2,673
    Thanks
    3
    Thanked 211 Times in 171 Posts
    Hard to explain without photo's. Basically they're a 2 piece plug and the lower peice has hardly any clearance to the side of the plug tube. Carbon gets in the tiny space and seizes it tight. Then when you try to loosen them, the hex turns but the lower part doesn't and they break off. Being 2 piece makes it even worse than it would have been. The trick is to crack them loose off the seat, then spray some solvent (carb cleaner, PB Blaster, etc) in the tube and let it sit a bit. Then, doing something they tell you to NEVER do, you use an impact to run them out. Sometimes it works, other times it doesn't. There is a special tool kit made specifically to extract the broken off part from the head that works fairly decent. Almost as bad as the 2 valve 4.6/5.4 where they had about 4 threads in the head for the plug to screw into. Seriously, the threaded portion was about 5/16". Can't recall how many of those plugs I've seen that blew right out of the head. As with the 3 valve, there is also a special tool kit to put threaded inserts in to save the head. It's like Ford went from bad to bad, lol.

    Here's a photo of the silly plugs they used and a couple broken ones:
    Attached Thumbnails Attached Thumbnails ford plugs.jpg  
    Last edited by aspen79; 01-10-2021 at 06:57 PM.
    1979 Aspen Sunrise 500". Bought in 1987 with 72,000 miles and a mighty E24 California emission 90hp leaning tower of power/4-speed
    1996 Dakota with a torque monster (not) 3.9L V-6 and automatic owned since 1998. Now demoted to winter duty
    2008 Ford Mustang V6, the new summer daily driver

  7. #7
    Super Moderator 77rr2x4s's Avatar
    Join Date
    Oct 2015
    Country:
    United States
    Posts
    1,776
    Thanks
    13
    Thanked 94 Times in 86 Posts
    Ok, I vaguely remember that issue with the V10 in a motor home that I was going to buy but decided against it after checking it out. I didn`t know that Ford had that same issue with the others. Wow.

  8. #8
    Aspen and Volare Super Moderator aspen79's Avatar
    Join Date
    Oct 2015
    Location
    Rib Mountain (Wausau) WI
    Country:
    United States
    Posts
    2,673
    Thanks
    3
    Thanked 211 Times in 171 Posts
    The plug blowing out problem applied to the V-10 as well. Very poor design.
    1979 Aspen Sunrise 500". Bought in 1987 with 72,000 miles and a mighty E24 California emission 90hp leaning tower of power/4-speed
    1996 Dakota with a torque monster (not) 3.9L V-6 and automatic owned since 1998. Now demoted to winter duty
    2008 Ford Mustang V6, the new summer daily driver

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •